Bob Peddle

asked May 10, 2010 at 6:50am
Canon Canon LBP 4

Canon i80 printer

I have an error on a Canon i80. After initialisation, the printer makes a loud buzzing noise and the green/orange LED flashes orange 4 times. The laptop advises of a service error 5C00. I have tries to reset the printer, but this makes no difference. Is it possible to remove the printer assembly from the lower case, I have the top cover removed.

Bob
Were you able to resolve this issue? I am having the same problem and can't find a solution. Thank you.
by cdrollins on Jun 8, 2010 at 4:15pm Add comment
Hi,
Yes, I have found the problem with the loud buzzing noise during start up and the orange light flashing 4 times.
The problem is due to the white plastic gear which drives the belt (the first gear interfaced to the motor). The gear has split radially and jamming the motor drive. If you turn the gear gently, you can inspect the condition of the plastic gear, or, power up with the top cover removed you will see the location of the gear jam if this is problem. The situation now is, that at present, I cannot obtain a replacement gear - only a new print engine!!!!

Bob - Bob Peddle
1. Start with printer OFF
2. Hold down RESUME and then hold down POWER
3. Release RESUME
4. press RESUME twice, then release POWER
5. let green light blink until printhead has finished moving.
6. Select functions below with RESUME, execute with POWER


now try press resume button 4 times..after that press the power button
by unknown on Jun 8, 2010 at 8:28pm Add comment
Hey Bob, I just inspected my printer and I have the same problem. Did you ever find a gear for it?

Thanks
by unknown on Jul 29, 2010 at 10:49am Add comment
Hi Alex,
No, I did not. I have been advised you have to purchase the whole print engine - rediculous!!!

Bob
by Bob Peddle on Jul 29, 2010 at 11:41am Add comment
Canon i80 only prints every second line.How do you fix it
by peter j on Oct 26, 2014 at 7:07pm Add comment