unknown

asked Nov 18, 2004 at 11:40pm
Epson Epson Stylus Color 640

640 Printer Down !

Can anyone HELP, I've got a Epson 640 Stylus i've had it for 6 years and what a great little printer it's been, but yesterday to my amazement it stopped working, the ink lights came on, the paper jam light is flashing and the on/off button is flashing, can anyone out there HELP me. Thanx Terry
If all the lights are flashing then it's a "Maintenance request error" But if the power light and the paper out light is flashing and ink lights are on solis then you have a fatal error.

A fatal error can be caused by almost anything. The first thing I would do is clean and oil the carriage guide shaft.

If you have all lights flashing then you can use the SSC utility to reset the protection counter (waste ink counter) You can download the SSC utility from here http://inkjetprinterhelp.us/epsonSSC.html

For more info on your printer you can use this link http://inkjetprinterhelp.us/440.html and look around on that site. Check the printer maintenance page http://inkjetprinterhelp.us/Printermaint.html for info on the carriage guide shaft.

I hope this helps,

Wes.
by unknown on Nov 18, 2004 at 11:55pm Add comment

Dear Wes

Thanx for your time, unfortunately i've downloaded the sevece pack but still the same result, all the lights on the printer are flashing. it still goes through the first phase of starting up then the lights start flashing.
any more suggestions, what about buying a new printer,

Thanx Terry
by unknown on Nov 19, 2004 at 1:19pm Add comment
Try holding all the buttons on the priner control panel then press the power switch. Hold the buttons for a few seconds then release them. That should reset the protection counter. You may need to repeat the process a few time to get the timing right.

I hope this helps,

Wes.
by unknown on Nov 20, 2004 at 7:58pm Add comment
I have an epson 640 printer you can have for 10 dollars plus ship. chet
by unknown on Dec 5, 2004 at 9:47pm Add comment
Sell it on eBay. No free ads here sparkie!
by Anonymous on Dec 5, 2004 at 10:45pm Add comment
Hi, my epson 640 works great, until I had install the Windows XP, since then I have some problems like can't abort the printing, but the worst thing, and this is my main question. The carriage run's from one side to the other several times before and after printing and sound like something inside jumps the gears, then when I turn off the carriage doesn't go to the rigth end. Today the 3 ligths start blinking. I turn off and then I move manualy the carriage to the rigth end position and restart and I can print, but the noise stil sound.
by Anonymous on Dec 17, 2004 at 9:58pm Add comment
Hi, my epson 640 works great, until I had install the Windows XP, since then I have some problems like can't abort the printing, but the worst thing, and this is my main question. The carriage run's from one side to the other several times before and after printing and sound like something inside jumps the gears, then when I turn off the carriage doesn't go to the rigth end. Today the 3 ligths start blinking. I turn off and then I move manualy the carriage to the rigth end position and restart and I can print, but the noise stil sound.
by unknown on Dec 17, 2004 at 10:00pm Add comment
That sounds more like a hardware problem than a software problem but the driver can contribute to the problem. Clean and oil the carriage guide shaft you can view this link for info on how to clean the guide shaft.

I hope this helps,

Wes.
by unknown on Dec 17, 2004 at 10:30pm Add comment