unknown

asked Nov 21, 2003 at 10:54am
Epson Epson Stylus Color 660

epson 660 not "parking" correctly

My epson 660 works fine (no clogging), but the problem is that it does not park correctly. It stops sort of in the middle of the printer. If you manually push it back to where it belongs, it will return when you turn it back on. I believe there is a way to let the printer know when it should be where it should, but I'm not sure how to do it. There is s "button" with a spring on the right that if you push it it allows you to move the print head without moving the controls on the left and I believe you would use this to move the head to the correct position. Any help would be appreciated?
Bruce: Does your printer make any grinding or ratcheting type noises when it is operating? Does the "Print Cartridge Holder Assembly"/"Printhead Assembly" ever slam over to the left side, causing the Red Service Error Lights to come on?...If so, then its possible that the "Carriage Assembly" is just DRY and DIRTY. If not, I would still recommend cleaning and lubing that carriage assembly, to see if that helps. If that does not help, then its possible that you may have a HARDWARE ERROR [parts problem], but there's no way for me to really know. Check your e-mail for some information that may help...Good Luck! Denny Conway
by Denny Conway on Nov 21, 2003 at 11:05am Add comment
Dennis, your suggestions worked great!

Thanks
by unknown on Nov 25, 2003 at 10:22am Add comment
Bruce: I'm glad to hear that it worked for you... Good Job! Denny
by Denny Conway on Nov 25, 2003 at 11:36am Add comment